aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar vnugent <public@vaughnnugent.com>2024-01-30 12:25:05 -0500
committerLibravatar vnugent <public@vaughnnugent.com>2024-01-30 12:25:05 -0500
commitac1e58837f1ba687939f78b5c03cadd346c10ddd (patch)
treeaf274dc4ced562f76a665502984c33892d92ca9c /CMakeLists.txt
parent8d25ae5e2dadf403d1d2d44a34bd5abd7107d74d (diff)
couple more tests, renable range checks, set flags for all projects
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 2 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3872f13..847f9fe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,14 +44,10 @@ if(MSVC)
$<$<CONFIG:Debug>:/FC> #show full path in diagnostics
$<$<CONFIG:Debug>:/showIncludes> #show a list of all included header files during build
- )
-
- #only target our project
- target_compile_options(
- ${CMAKE_PROJECT_NAME}
- PRIVATE
+
$<$<CONFIG:Debug>:/wd4820> #disable warnings for struct padding and spectre mitigation wuen WX is enabled
+ $<$<CONFIG:Debug>:/wd5045> #disable warnings for spectre mitigation insertion
#for debug configs
$<$<CONFIG:Debug>:/options:strict>
@@ -78,12 +74,6 @@ elseif(CMAKE_COMPILER_IS_GNUCC)
$<$<CONFIG:Debug>:-Og>
$<$<CONFIG:Debug>:-Wall>
$<$<CONFIG:Debug>:-Werror>
- )
-
- #only target our project if building other 3rd party libs in current build
- target_compile_options(
- ${CMAKE_PROJECT_NAME}
- PRIVATE
$<$<CONFIG:Debug>:-Wall>
$<$<CONFIG:Debug>:-pedantic>
)