aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar vnugent <public@vaughnnugent.com>2024-08-12 13:57:11 -0400
committerLibravatar vnugent <public@vaughnnugent.com>2024-08-12 13:57:11 -0400
commitfa5e809f465fc25d2872fe85983632b77f290062 (patch)
treee2ffc7daee461ae0946763e3227dfd801f087359 /CMakeLists.txt
parentfb3608b9455b3e0956e401e6254da13cebd71558 (diff)
Squashed commit of the following:v0.1.3
commit a6392806eae7f302031afbcf22664ba33cbc4ad1 Author: vnugent <public@vaughnnugent.com> Date: Mon Aug 12 13:56:03 2024 -0400 simple cleanup & some api notes commit a97012676cc836ec50ef5ff6d8e97134aa7a1d22 Merge: ec7461d fb3608b Author: vnugent <public@vaughnnugent.com> Date: Wed Aug 7 21:39:28 2024 -0400 Merge branch 'master' into develop
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 13 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 89b2026..4a10738 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -421,9 +421,20 @@ install(TARGETS ${_NC_PROJ_NAME}_static
INCLUDES DESTINATION include
)
-install(FILES
- include/noscrypt.h
+SET(NC_INSTALL_HEADERS
+ include/noscrypt.h #static install headers
include/platform.h
+)
+
+if(NC_ENABLE_UTILS)
+ LIST(APPEND
+ NC_INSTALL_HEADERS
+ include/noscryptutil.h
+ )
+endif()
+
+install(FILES
+ ${NC_INSTALL_HEADERS}
DESTINATION noscrypt
)