aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar vnugent <public@vaughnnugent.com>2024-08-12 13:56:03 -0400
committerLibravatar vnugent <public@vaughnnugent.com>2024-08-12 13:56:03 -0400
commita6392806eae7f302031afbcf22664ba33cbc4ad1 (patch)
treee2ffc7daee461ae0946763e3227dfd801f087359 /CMakeLists.txt
parenta97012676cc836ec50ef5ff6d8e97134aa7a1d22 (diff)
simple cleanup & some api notes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 13 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 89b2026..4a10738 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -421,9 +421,20 @@ install(TARGETS ${_NC_PROJ_NAME}_static
INCLUDES DESTINATION include
)
-install(FILES
- include/noscrypt.h
+SET(NC_INSTALL_HEADERS
+ include/noscrypt.h #static install headers
include/platform.h
+)
+
+if(NC_ENABLE_UTILS)
+ LIST(APPEND
+ NC_INSTALL_HEADERS
+ include/noscryptutil.h
+ )
+endif()
+
+install(FILES
+ ${NC_INSTALL_HEADERS}
DESTINATION noscrypt
)