aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar vnugent <public@vaughnnugent.com>2024-11-04 12:12:38 -0500
committerLibravatar vnugent <public@vaughnnugent.com>2024-11-04 12:12:38 -0500
commit7a01c636f60a706f4eda2ad0e56afeffd22d30d1 (patch)
tree81dc135e757f0657a162aaec30f4782d5001b14b /CMakeLists.txt
parent7ec20facaff2e38b2cdb2f445bda1d5a237e1ea7 (diff)
readme + changelog updates
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4a10738..8c2e700 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -272,6 +272,8 @@ if(MSVC)
/sdl #enable additional security checks
/TC #compile as c
/GS #buffer security check
+
+ $<$<CONFIG:Debug>:/fsanitize=address>
$<$<CONFIG:Debug>:/FC> #show full path in diagnostics
$<$<CONFIG:Debug>:/showIncludes> #show a list of all included header files during build