aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar vnugent <public@vaughnnugent.com>2024-08-08 14:51:37 -0400
committerLibravatar vnugent <public@vaughnnugent.com>2024-08-08 14:51:37 -0400
commitf8ec3640e4ba2249fcc0ba324ac5b071e5d6f40b (patch)
tree61d3b053ca81fa657754852550d03305b618d15b /CMakeLists.txt
parentb69876b1786f5e99448266a3b74ca4404d7118fd (diff)
add noscrypt cipher and update for new noscrypt utils api
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b933d9..89894cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,7 +57,7 @@ include_directories(${uuid_v4_SOURCE_DIR})
FetchContent_Declare(
libnoscrypt
GIT_REPOSITORY git@github.com:VnUgE/noscrypt.git
- GIT_TAG v0.1.2
+ GIT_TAG fb3608b9455b3e0956e401e6254da13cebd71558
)
FetchContent_MakeAvailable(libnoscrypt)
@@ -65,6 +65,7 @@ FetchContent_GetProperties(libnoscrypt)
include_directories(${libnoscrypt_SOURCE_DIR}/include)
set_target_properties(noscrypt PROPERTIES CRYPTO_LIB openssl)
+set_target_properties(noscrypt PROPERTIES NC_ENABLE_UTILS ON) #utilities library is required
#======== Build the project ========#
set(INCLUDE_DIR ./include)
@@ -98,6 +99,7 @@ set(SOURCES
${DATA_SOURCE_DIR}/filters.cpp
${SERVICE_SOURCE_DIR}/nostr_service_base.cpp
${SIGNER_SOURCE_DIR}/noscrypt_signer.cpp
+ ${SIGNER_SOURCE_DIR}/noscrypt_cipher.cpp
)
add_library(aedile ${SOURCES} ${HEADERS})